2

I log in with a StackExchange account. I've been hitting the Questions board pretty frequently on my iPhone and find that it logs me out just as frequently. So I go into 1Password, copy my password, go back to Mobile Safari, type in my email address, paste in my password and can finally log in.

Do we know if there's any Remember Me functionality that can be enabled on the StackExchange log in screen?

3 Answers 3

1

I use the gmail option for logging in and have never been logged out on my end on web or mobile.

6
  • Good to know. I'll give that a try. Thanks! Commented Jan 28, 2013 at 17:36
  • You may need to update the email address you are using on your SE accounts to match the gmail account for this to get things working correctly.
    – Anna_MediaGirl Mod
    Commented Jan 28, 2013 at 17:37
  • 1
    I added Google to my StackExchange logins and authorized it on the Google end, so I'll see what happens if I just use that for my login method next. Will report back on how that goes. My SE email should already be that email address. Commented Jan 28, 2013 at 17:38
  • Still happens on the iPhone / Mobile Safari unfortunately. I have just 1 tab open, but if I come back after too long, I'm logged out. Using my Google Apps account is a bit easier than my StackExchange account. Google Apps has the Remember Me checkbox on their login screen too. Any chance you have a tab open to Gmail or anything? Commented Jan 29, 2013 at 13:52
  • I use iPhone and FF on Windows 7 & 8. I don't keep a tab open.
    – Anna_MediaGirl Mod
    Commented Jan 29, 2013 at 16:33
  • I'm on iPhone 5 running iOS 6. I've not been logged out from EESE since November, possibly earlier. But November is when I really started using EESE on my iPhone, by putting a reference to it on my home screen. Commented Feb 16, 2013 at 19:17
1

I've not tried it for a while on an iPhone, but I recall that by default Safari is locked down to not accept cookies across sessions.

Check your Safari settings are set to allow Cookies from either "Visited" or "All Sites".

3
  • I have it set to Visited, and I've been wondering if this is the culprit as well. Are you saying that All Sites is the only way to support it? Commented Jan 30, 2013 at 17:20
  • Possibly yes - I believe the log in mechanism is actually through a different StackExchange site (I can't remember the exact sub-domain used off the top of my head) - which you wouldn't be explicitly visiting, so Safari is dropping the cookie. Commented Jan 30, 2013 at 17:35
  • @MarkJ.Reeves Actually it might just be the root: stackexchange.com - try visiting that and logging in and see how you get on. Commented Jan 30, 2013 at 17:37
1

Thanks everyone for the tips. I've been able to stay logged in since yesterday in Mobile Safari after setting Private Browsing: Off.

It would stay logged in for short periods of time despite leaving leaving Safari, which confused things a bit.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .